Difference between revisions of "OpenFOAM"

From LWP-Wiki
Jump to: navigation, search
(Created page with "OpenFOAM cnd this can cause conflicts with extensions and/or versions. The people creating the foam extensions are aware of this thankfully and have made it so that you can in...")
 
Line 1: Line 1:
OpenFOAM cnd this can cause conflicts with extensions and/or versions. The people creating the foam extensions are aware of this thankfully and have made it so that you can install the extensions into your own home directory without requiring elevated privileges. This way multiple users on the same system can use their own versions and extensions. I've just verified that it works, with an unprivileged account, on your system. I've added the actual commands I've used for the installation below, which are pretty much the instructions from the links you've sent. Compilation of the extensions will take some time. Run the following commands to make it happen.
+
Both openFOAM repositories (org & com) are available on the LWP. Instructions on how to install packages on the LWP can be found [[install packages| here]]. Students do not have permission to install software, because the PCs in the computer rooms need to diverge as little as possible, but you can send us a request to install it on your system, by using the "support request" icon on the desktop or selecting it from the menu.
  
 +
Since there are quite a few versions of openFOAM(com/org) and it's extensions floating around, installing a version on a system can cause conflicts for other users on that system. Thankfully the foam developers recognize this and have made it possible to install a version or extensions into your own home directory without requiring elevated privileges. This way multiple users on the same system can use their own versions and extensions. Compilation of some of these will take some time.
  
# apt install openfoam2112 openfoam2112-dev gfortran-10
+
The following FOAM extensions have been verified to work for unprivileged users:
  
# First set up the requirements for openFOAM:
+
Install (or request we install) the following packages on your system:
cd ~
+
$ apt install openfoam2112 openfoam2112-dev
mkdir foam
 
cd foam
 
curl https://www.paraview.org/paraview-downloads/download.php\?submit=Download\&version=v5.10\&type=binary\&os=Linux\&downloadFile=ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz -o ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz
 
tar xzf ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz
 
echo "export PATH=~/foam/ParaView-5.10.1-MPI-Linux-Python3.9-x86_64/bin:$PATH" >> ~/.bashrc
 
echo "source /usr/lib/openfoam/openfoam2112/etc/bashrc" >> ~/.bashrc
 
source ~/.bashrc
 
openfoam2112
 
exit
 
  
# Installing foam-extend-4.1:
+
First set up the requirements for openFOAM:
cd ~
+
cd ~
mkdir foam
+
mkdir foam
cd foam
+
cd foam
git clone git://git.code.sf.net/p/foam-extend/foam-extend-4.1
+
curl https://www.paraview.org/paraview-downloads/download.php\?submit=Download\&version=v5.10\&type=binary\&os=Linux\&downloadFile=ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz -o ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz
cd ~/foam/foam-extend-4.1
+
tar xzf ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz
source etc/bashrc
+
echo "export PATH=~/foam/ParaView-5.10.1-MPI-Linux-Python3.9-x86_64/bin:$PATH" >> ~/.bashrc
echo "alias fe41='. ~/foam/foam-extend-4.1/etc/bashrc'" >> ~/.bashrc
+
echo "source /usr/lib/openfoam/openfoam2112/etc/bashrc" >> ~/.bashrc
source ~/.bashrc
+
source ~/.bashrc
./Allwmake.firstInstall -j8
+
openfoam2112
 +
exit
 +
 
 +
Installing foam-extend-4.1:
 +
git clone git://git.code.sf.net/p/foam-extend/foam-extend-4.1
 +
cd ~/foam/foam-extend-4.1
 +
source etc/bashrc
 +
echo "alias fe41='. ~/foam/foam-extend-4.1/etc/bashrc'" >> ~/.bashrc
 +
source ~/.bashrc
 +
./Allwmake.firstInstall -j8 # the -j<number> refers to the number of CPU cores to use for compiling the software (more = faster)
  
 
# Installing OlaFlow:
 
# Installing OlaFlow:
git clone git://github.com/phicau/olaFlow.git
+
git clone git://github.com/phicau/olaFlow.git
cd olaFlow
+
cd olaFlow
./allMake -j8
+
./allMake -j8
  
 
# Installing solids4foam:
 
# Installing solids4foam:
mkdir -p $FOAM_RUN
+
mkdir -p $FOAM_RUN
cd $FOAM_RUN/..
+
cd $FOAM_RUN/..
git clone https://bitbucket.org/philip_cardiff/solids4foam-release.git
+
git clone https://bitbucket.org/philip_cardiff/solids4foam-release.git
./Allwmake -j8
+
./Allwmake -j8

Revision as of 16:37, 30 March 2022

Both openFOAM repositories (org & com) are available on the LWP. Instructions on how to install packages on the LWP can be found here. Students do not have permission to install software, because the PCs in the computer rooms need to diverge as little as possible, but you can send us a request to install it on your system, by using the "support request" icon on the desktop or selecting it from the menu.

Since there are quite a few versions of openFOAM(com/org) and it's extensions floating around, installing a version on a system can cause conflicts for other users on that system. Thankfully the foam developers recognize this and have made it possible to install a version or extensions into your own home directory without requiring elevated privileges. This way multiple users on the same system can use their own versions and extensions. Compilation of some of these will take some time.

The following FOAM extensions have been verified to work for unprivileged users:

Install (or request we install) the following packages on your system:

$ apt install openfoam2112 openfoam2112-dev

First set up the requirements for openFOAM:

cd ~
mkdir foam
cd foam
curl https://www.paraview.org/paraview-downloads/download.php\?submit=Download\&version=v5.10\&type=binary\&os=Linux\&downloadFile=ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz -o ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz
tar xzf ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz
echo "export PATH=~/foam/ParaView-5.10.1-MPI-Linux-Python3.9-x86_64/bin:$PATH" >> ~/.bashrc
echo "source /usr/lib/openfoam/openfoam2112/etc/bashrc" >> ~/.bashrc
source ~/.bashrc
openfoam2112
exit

Installing foam-extend-4.1:

git clone git://git.code.sf.net/p/foam-extend/foam-extend-4.1
cd ~/foam/foam-extend-4.1
source etc/bashrc
echo "alias fe41='. ~/foam/foam-extend-4.1/etc/bashrc'" >> ~/.bashrc
source ~/.bashrc
./Allwmake.firstInstall -j8 # the -j<number> refers to the number of CPU cores to use for compiling the software (more = faster)
  1. Installing OlaFlow:
git clone git://github.com/phicau/olaFlow.git
cd olaFlow
./allMake -j8
  1. Installing solids4foam:
mkdir -p $FOAM_RUN
cd $FOAM_RUN/..
git clone https://bitbucket.org/philip_cardiff/solids4foam-release.git
./Allwmake -j8