Difference between revisions of "OpenFOAM"

From LWP-Wiki
Jump to: navigation, search
Line 17: Line 17:
 
  exit
 
  exit
  
'''Installing foam-extend-4.1''':
+
'''Installing foam-extend-4.1''':
# If you've skipped the part "Set up the requirements" then run the following command first:
+
If you've skipped the part "Set up the requirements" then run the following command first:
 
  source /usr/lib/openfoam/openfoam2112/etc/bashrc
 
  source /usr/lib/openfoam/openfoam2112/etc/bashrc
 +
 
  cd ~/foam/
 
  cd ~/foam/
 
  git clone git://git.code.sf.net/p/foam-extend/foam-extend-4.1
 
  git clone git://git.code.sf.net/p/foam-extend/foam-extend-4.1
Line 32: Line 33:
 
''To use the latest version of Paraview, follow the instructions [[Paraview| here]]''
 
''To use the latest version of Paraview, follow the instructions [[Paraview| here]]''
  
'''Installing OlaFlow''':
+
'''Installing OlaFlow''':
 
If you've skipped the part "Set up the requirements" then run the following command first:
 
If you've skipped the part "Set up the requirements" then run the following command first:
 
  source /usr/lib/openfoam/openfoam2112/etc/bashrc
 
  source /usr/lib/openfoam/openfoam2112/etc/bashrc
Line 41: Line 42:
 
  ./allMake -j8
 
  ./allMake -j8
  
'''Installing solids4foam''':
+
'''Installing solids4foam''':
 
If you've skipped the part "Set up the requirements" then run the following command first:
 
If you've skipped the part "Set up the requirements" then run the following command first:
 
  source /usr/lib/openfoam/openfoam2112/etc/bashrc
 
  source /usr/lib/openfoam/openfoam2112/etc/bashrc

Revision as of 12:33, 31 March 2022

Both openFOAM repositories (org & com) are available on the LWP. Instructions on how to install packages on the LWP can be found here. Students do not have permission to install software, because the PCs in the computer rooms need to diverge as little as possible, but you can send us a request to install it on your system, by using the "support request" icon on the desktop or selecting it from the menu.

Since there are quite a few versions of openFOAM(com/org) and it's extensions floating around, installing a version on a system can cause conflicts for other users on that system. Thankfully it's possible to install a version or extensions into your own home directory without requiring elevated privileges. This way multiple users on the same system can use their own versions and extensions. Compilation of some of these will take some time.

The FOAM extensions described here have been verified to work for unprivileged users.

Install (or request we install if you login with a S#) the following packages on your system:

$ sudo apt install openfoam2112 openfoam2112-dev

Set up the requirements for openFOAM:

cd ~
mkdir foam
cd foam
echo "source /usr/lib/openfoam/openfoam2112/etc/bashrc" >> ~/.bashrc
source ~/.bashrc
openfoam2112
exit

Installing foam-extend-4.1: If you've skipped the part "Set up the requirements" then run the following command first:

source /usr/lib/openfoam/openfoam2112/etc/bashrc
cd ~/foam/
git clone git://git.code.sf.net/p/foam-extend/foam-extend-4.1
cd foam-extend-4.1
source etc/bashrc
echo "alias fe41='. ~/foam/foam-extend-4.1/etc/bashrc'" >> ~/.bashrc
./Allwmake.firstInstall -j8   # the -j<number> refers to the number of CPU cores to use for compiling the software (more = faster)

# You will be asked to proceed WITHOUT compiling Paraview; Choose yes. The supplied version is much older then the one currently installed.
Proceed without compiling ParaView [Y/n] y

To use the latest version of Paraview, follow the instructions here

Installing OlaFlow: If you've skipped the part "Set up the requirements" then run the following command first:

source /usr/lib/openfoam/openfoam2112/etc/bashrc
cd ~/foam/
git clone https://github.com/phicau/olaFlow.git
cd olaFlow
./allMake -j8

Installing solids4foam: If you've skipped the part "Set up the requirements" then run the following command first:

source /usr/lib/openfoam/openfoam2112/etc/bashrc
cd ~/foam/
mkdir -p $FOAM_RUN
cd $FOAM_RUN/..
git clone https://bitbucket.org/philip_cardiff/solids4foam-release.git
./Allwmake -j8